?

Log in

No account? Create an account
Previous Entry Share Next Entry
Unable to access ecryptfs home folder
anime
he_the_great
Update: I feel I have verified that my access issues with my encrypted home were with utilizing an older version of ecryptfs. Yesterday I installed the latest testing and was able to mount my private home.

I started using an encrypted home Private folder as outlined in some many posts. This is a cautionary tail probably due to a bug I do not wish to track down.

Recently I had my partition table corrupted and I was unable to access my data. Supposedly all you need to recover your data is to know your login information or the encryption passphrase.

To get to my data (while I was trying to figure out what was wrong with the system hard drive) I had installed a fresh Debian Linux and mounted my home directory as I've done so many times before. Now that I have my ~/.ecryptfs folder and my Private/.Private folders back in their proper location, it should have been a simple $ ecryptfs-mount-private and provide my old login password. No such luck, claims the passphrass is wrong.

Ok, ok. Maybe I did something wrong there. Now I'll just mount private manually. I already know the passphrase my login password was used to wrap so it should be simple enough. Nope. Still no luck mounting even though I know the encoding passphrase.

I think that there may be a version miss-match that has caused this issue, but at this time I have not verified this. This is a cautionary tail that recovery may not be as simple as it has been made out to be.